Issues with amass subdomain enumeration?

Does anyone use amass for subdomain enumeration? I’ve heard nothing but good things about it, yet I’ve had nothing but issues. It randomly decides when to work and when to not work. I get this error every time:

cannot change profile for the next exec call: No such file or directory
snap-update-ns failed with code 1: No such file or directory

Rebooting doesn’t help, restarting the service doesn’t help, nothing I’ve found on the interwebs helped. If anyone has seen something similar with amass, please let me know. Otherwise, I guess I’m going to back to good ol’ sublist3r.

I guess you installed it using snap?
If that’s the case, try downloading the binaries from the repository or building it from the source code which is not difficult.

@stefanofinding, yes, it was with snap and I also tried it with Go. It’s just strange that it works like half the time. I’ll need to just get rid of it entirely and try again from scratch. If that isn’t working, then I’ll cut my losses lol. Thank you!

Interesting. I installed it using snap on Ubuntu 18.04 and it has been working without any issues.
Did you get the same error when running the one you built from the Go sources?

@stefanofinding, yeah, so I ended up figuring it out. What I think had happened was I first installed it in Go, but it just wasn’t working at all (I did not install it correctly). So I used snap, but I think there were some conflicts with it being installed twice since I don’t think I removed it entirely before installing it via snap. It was just weird that it was working sometimes and not others. I just blew both away and started over with only snap and have had no problems since. So, a complete idiotic mistake on my part lol. Thank you!!

@pisteuo I’m glad you figured it out!