Proxy Burp issue

I followed Web-hackers handbook correctly, as well as Burp correctly

So I opened burp> settings checked my IP 127 prt 8080
I also checked edit in burp, noticed a different IP started with 10 than Burp showed above the 127 , not matching loop, so I changed it loop saved.

go to firefox browser on my virtual box desktop > settings> network> put 127 IP , checked Use this for all protocols box

got the certificate > added …everything worked…
until, I closed burp…
my Firefox wont work unless I uncheck the Use this for protocols box and set it back to no proxy. Worse, I open Burp and its back IP 127 ort 8080 but in edit> back to my IP starting with 10 .

What did I do wrong?